Hello! I have a pixel 7 with GrapheneOS, and would like to install eSpeak as TTS engine. On fdroid there is no release available, and on github if I download the apk and try to install it, a “the app cannot be installed because your device is not compatible” error is thrown. Why this? And how can I install it?

  • @j4k3@lemmy.world
    link
    fedilink
    English
    34 months ago

    I never compiled for android, but like, with GCC it’s just a flag and (learning hobbyist so don’t take my word for it) it just has to do with variable byte lengths. You should be able to just compile for 64 bit and it should work. A few variable types will just be longer by a couple of bytes in memory, but it will have no impact overall… I think… At least that’s what the chapter from Computer Systems A Programmer’s Perspective -Bryant/O’hallaron said when I was reading it earlier today.

  • @parpol@programming.dev
    link
    fedilink
    English
    14 months ago

    Did you try building the APK yourself from the source?

    Maybe it is reliant on google play services or uses libraries not available on GrapheneOS due to privacy issues with those libraries?